No water coming from cylinder head.

Having problems with a Seagull? - ask an expert here

Moderators: John@sos, charlesp, Charles uk, RickUK, Petergalileo

Post Reply
Lokki
Posts: 3
Joined: Sat Jul 31, 2021 10:29 am
Location: Finland

No water coming from cylinder head.

Post by Lokki »

Hello my friends!

I got myself an old seagull with an LLS 35167 stamp.
Flywheel has the date 10/62.

At first it had no spark. Good compression though.
Spark plug lead had corrosion so bad that a multimeter couldn't go trough.
Fixed it by sanding the screw that punctures the lead under the spring.

Then i opened up the breaker box and sanded down the contacts and boom i got spark.
Coil seems to be normal. around 8 ohms on the multimeter once magnet passes by.

Motor starts to run. Everything works. Got good push from the motor but i have no water dripping from the water hole on the cylinder head.. Only smoke coming from there if it's running for a longer time and getting hot.
I flushed the system with a hose and water is going trough.. Also pushed compressed air trough the hole and it's coming out the bottom.

I tried pushing air from the bottom slits and i heard the water pump spinning freely. I'm assuming this is a no-no.


Where can i get an waterpump impeller for my seagull? I'll probably need gaskets too..
I live in Finland.
User avatar
Collector Inspector
Posts: 4075
Joined: Sun Jun 29, 2008 4:32 am
Location: Perth Western Australia
Contact:

Re: No water coming from cylinder head.

Post by Collector Inspector »

Contact John SOS

Everything needed for you there.

Start here and get cracking!


http://www.saving-old-seagulls.co.uk/bu ... spares.htm

B
A chicken is one egg's way of becoming others
Lokki
Posts: 3
Joined: Sat Jul 31, 2021 10:29 am
Location: Finland

Re: No water coming from cylinder head.

Post by Lokki »

Fixed the issue. Thanks to John!
Romainpek
Posts: 22
Joined: Wed May 12, 2021 2:26 pm
Location: Saint Germain en Laye

Re: No water coming from cylinder head.

Post by Romainpek »

How could the water pump spin freely ? It is tightly fitted around the square drive shaft... what was wrong ?
Lokki
Posts: 3
Joined: Sat Jul 31, 2021 10:29 am
Location: Finland

Re: No water coming from cylinder head.

Post by Lokki »

Apparently there was just some gunk there creating a whirring sound.. Waterpump works fine. Just forgot to take the prop off when running in a bucket.
Post Reply